Проблема скорее всего в том, что вы файл в папке PlayParse не заменили, т.к. обменник, как я только что заметил, заменяет пробелы и тире на знак подчёркивания и название файла, соответственно, тоже меняется. Поправил этот пост, заменил файл на архив с правильным названием файла внутри. Замените файл, обновите в настройках, как написано в том же посте и всё должно работать.

Только что проверил с текущей стабильной версией и заменой, любые ролики начинают работать и 1 и 3 часа из вашего же плейлиста.
Плейлист , например, строка 62, трек на 3 часа не воспроизводится, в принципе ровно как и 90% всеъ треков плейлиста

а например 59 строка на 55 минут без проблем воспроизводится
Только что проверил случайный ролик 1ч15 в плеере с заменой файла парсинга, не вижу проблем. Дайте ссылку на проблемный ролик хотя бы один.
у меня не воспроизводятся видосы высокой продолжительностью, 1 , 2 и т.д. часа (музыкальные миксы), прога официальная, свежая, файлик из комментов заменял, не помогает, как быть? 
Читайте мой комментарий ниже про проблемы с роликами Ютуба.
У меня любые ролики с ютуба вообще не открываются с ошибкой. А в плейлист добавляется лишь одна ссылка на сам плейлист вместо списка видео. Проверял на двух портативных сборках. ТВ каналы работают. OS winXP. Что виновато и кто делать? Пробую разобраться.
Подскажите, как допавить плагин в PotPlayer winamp DSP izotope ozone, обычная версия плеера видит, а версия от 7sh3 нет.
Спасибо!
Если у кого-то проблемы с проигрыванием некоторых роликов, то для решения смотрим сюда.
У кого в версии 1.7.14804 и более ранних проблемы с проигрыванием роликов YouTube для исправления нужно сделать следующее:

  1. Скачать этот архив
  2. Закрыть плеер, скопировать из скачанного архива файл MediaPlayParse - YouTube.as по пути _папка_установки_плеера\Extention\Media\PlayParse и согласиться на замену (важно! старый файл должен быть заменён)
  3. Открыть плеер, зайти в настройки (F5) - "Расширения" - "Адрес медиа" и нажать "Обновить"
  4. Если всё сделано верно, то проблема должна исчезнуть

Указанный выше файл взят из бета версии PotPlayer. В следующей стабильной версии проблема парсинга YouTube будет уже, соответственно, решена.
защищенные авторским правом (те же муз. клипы, например)
Тогда советую уточнить момент с ошибкой на форуме.
сборку ставил, потом отдельно svp ставил...
Я не в теме, видимо, что такое "копирайтнутые"?
Не работают ролики по ссылке, причем копирайтнутые (Раньше такого не было); Версия плеера - последняя
Похоже, что у вас просто файл фильтра отсутствует, который включает скрипт при активации плавности. У вас сборка 7sh3 или вы ставили SVP сами на обычную версию PotPlayer?